Jump to content

270H 72106 Electrical issue

Recommended Posts


My 1999 270H with 48” deck is having an issue getting power to PTO.   Checked PTO with jumper to battery and it worked fine and I’ve actually been cutting grass using the jumper for awhile.  I checked power from PTO switch to PTO and there is none.  I checked PTO switch and it appeared OK but I replaced it anyway and still no power to PTO.   Then checked brown/tan wire leading to switch and there is none.   Could the issue be the NMIR module and is there a good way to check it.  If bad, where is the best place to get a replacement and do other brands/models have NMIR a modules I can use.    Also, would suppling battery power directly to PTO switch and bypassing NMIR result in switch working.

Edited by decvt79

Share this post

Link to post
Share on other sites

I would go back to the wiring diagrams you can download and follow the pto ones to see what is working and what is not.


Since you had the transmission out one of the switches associated with it may be the problem.

Yes there is way to check the NMIR already provided earlier.

Isolate the problem before you waste hundreds on parts you don't need.

To find the earlier posts click on your decvt79

  • Like 1
  • Excellent 1

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • the jeep driver
      By the jeep driver
      My daughter was using the Wheel Horse rider to mow, I was push mowing.  She drives over to me and says, "Dad, the blades aren't turning." I look at the mower, she's got the blades engaged (lever forward) but nothing is moving.  I disengage the blades, and re-engage... nothing.  No movement from the belt nor clutch.  Then I notice the smell, and look closer, the belt is so hot is melting on the clutch.  Or rather, the clutch is so hot it's melting the belt.  Melting occurred. 

      While the clutch is disengaged, I can spin the clutch freely; and whilst it's engaged, it won't move. 

      So, what did I do now?  Peter told me to lube that needle bearing, but I couldn't find a write up/how to anywhere, so I was putting it off until after the leaves were done falling in the Fall.  I haven't taken anything off yet, other than the pins that hold the pinion and such, and the little brake pad.  I see there are two snap rings, assume they come off, and then the assembly slides out as a whole? 

      Some pictures of the clutch, can anyone tell if it's usable from them?



    • trident
      By trident
      Need some help. My 800 Special has an electric PTO. It is not working. Checked Ohms - nothing. My questions are 1) how does the PTO come off and 2) can they be rebuilt? I took the bolt out that I thought holds it on but no luck. Must be something more?
    • BMW1
      By BMW1
      What direction does the front PTO Pulley turn on a wheel horse D180 with a Kohler K482 as you face the front of the tractor?
      I want to get a hydraulic pump for a Johnson 10 loader I will be mounting to tractor and want to make sure I get a pump that rotates the correct direction.
    • DMB41
      By DMB41
      Hi All,
      My first post on here so apologies in advance for any rookie mistakes.
      First off, I am the proud owner of a "new to me" 312-8. I took it out for a spin yesterday and when I engaged the PTO, currently there is a 42 in side discharge mower deck on it, there were sparks flying from the disk directly below the muffler (maybe the flywheel or clutch?). Any idea what that may be and what needs to be addressed?
      Thank you !!
    • Capsbearsfan
      By Capsbearsfan
      Hello,  I am new here.  Sorry if this is not in the correct place.
      i have a 210-5 (38” single blade) was mowing and hit something hard that shut everything off.  I turned the pto off, restarted the engine without an issue, but now the pto will not engage.  I did check the belt, and not sure what to look at past that.  Any direction would be great.
      thabk you.
  • Create New...