Jump to content
Armin Buehlmann

PTO kills engine, seat safety switch ok

Recommended Posts

Armin Buehlmann


I read through a few related posts but my symptoms sound different.

Have an '89-'90? Wheelhorse 520-H,  model 4120OE01.

When I engage the PTO, the engine stalls. No fault indicators.

However, everything else seems normal:

- all lights work when pressing 'TEST'

- when I engage the PTO without sitting on the seat, the engine also stalls, but the 'SEAT' light comes on. Normal.

- when I try to start the engine with the PTO engaged, it won't start and 'PTO' lights up. Normal.

- after disconnecting the load (2-stage snow blower belt in this case) from the PTO, I get the same problem, engine stalls immediately. PTO pulley turns along fine with the remaining motion.


And I also need to mention: the first time it happened it was intermittent. The tractor and snowblower attachment were used over a month ago, without any problem.This time got above symptom upon startup. I didn't feel like shoveling so after revving the engine for a minute or two and a few 'encouraging' words, it worked.  I switched the PTO off and on several times afterwards with no problem (engine warm, obviously). Today, with the engine cold, the problem is back.


I think there's enough reason to rule out the PTO- and seat- switches. But what else should I check? 

This is my first time writing in the forum and I hope I've given enough clues without boring you.

Any hints and advice are appreciated.



PS any good tricks to counteract the belt tensioner on the 2-stage snow thrower (model 79361)? It is a bear to connect and disconnect.


Share this post

Link to post
Share on other sites

These diagrams should help you solve the problem.

Check the 9-pin connector between the tractor wiring and the engine wiring. Look for a darkened plastic connector from overheating and if so the wiring is corroded. The wire connectors could also be corroded without showing signs of overheating.


The seat switch has two positions. One powers the idiot light and the other powers the ignition circuit. It is possible for only the ignition side to fail and not power the ignition. A test light or voltmeter would determine the condition.

Keep us posted on your progress.



  • Like 1

Share this post

Link to post
Share on other sites
953 nut


Your PTO switch serves two functions, Half of the switch is tied into the "START" circuitry and the other half is in the  "IGNITION" flow path. If one of the wiring connections to the PTO switch is loose or corroded it could be the problem.        Also, many newer wiring harnesses use relays to kill the ignition. They are located below the battery and the connections are subject to corrosion due to fumes from the battery. 

Edited by 953 nut
  • Like 1

Share this post

Link to post
Share on other sites
Armin Buehlmann
On 1/20/2020 at 6:04 PM, gwest_ca said:

These diagrams should help you solve the problem


Thank you Garry,

very prompt, informative and encouraging to keep looking.

It is back up and running but as it was as sporadic problem, I'm not yet sure of the root cause. It's all about knowing about the double switch functions, and studying the wiring diagram.

Bought a test light, found no weak connections and wound up replacing 2 switches. If the issue comes back I'd replace the lower of the two orange wires (seat switch to 9-pin). I'll post again after extended use.

Some forum experience that might help other first-time users:

I only looked at the email, got encouraged about the additional information, and dug up my own wiring diagram. Spent quite some time just to figure out which switch is which, as they are unlabeled, just as on the one provided on the email. Only to see today that the forum post contains more detail. Lesson learned: read the forum replies :)


Share this post

Link to post
Share on other sites
Armin Buehlmann
On 1/21/2020 at 6:32 AM, 953 nut said:


Your PTO switch serves two functions, ....

Thank you Richard, 

yes it is important to know that the magic happens in multiple three-way switches, and the PTO lever activates two. Actually de-activates, because turning on the PTO releases them into their neutral position.


Share this post

Link to post
Share on other sites
Armin Buehlmann


apologies for the long delay in closing this, but as you all know, times got weird.
Yes, it was the PTO switch. After replacing it, we had no more snow but all was well throughout the mowing season. After a long time on the workbench, the switch did occasionally fail to connect - 

Case Closed. Thanks again for all the help.

  • Like 2

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • davem1111
      By davem1111
      I'm trying to figure out how to fix two problems: 
      1. Drive belt from PTO to deck keeps flipping over between the PTO and the mule.  Everything looks okay, belt runs right between mule and deck. It cuts just fine, but I'm concerned that running the belt on its back through the PTO will shorten its life a lot.
      2. PTO handle kicks off at random times while engaged. Not doing anything unusual, just cruising along mowing, and boom, it flips back.  Missing spring maybe?
      Any ideas?
    • BrianKoch
      By BrianKoch
      Hello gentleman, 
      Problem: will not crank on its own, will crank with jump box—but still not fire
      Recent things I did prior to this issue: cleaned fuel filter, replaced battery cables, replaced cable from ignition to starter
      I have my test light out and am probing around. 
      There is no power at ignition/magneto wire or the ignition/starter wire
      There is power everywhere else

    • Jeff-C175
      By Jeff-C175
      Detailed wiring from the Demystification Guide #492-4509
      4 pages 1.4MB Color
      p7-67 to p7-70
      Onan powered
      1989 416-8 model 31-16O801
    • trident
      By trident
      Need some help. My 800 Special has an electric PTO. It is not working. Checked Ohms - nothing. My questions are 1) how does the PTO come off and 2) can they be rebuilt? I took the bolt out that I thought holds it on but no luck. Must be something more?
    • grasscuts
      By grasscuts
      Hi, here's what happened. I changed out 9 pin moles plug...had issues tracter quit running and changed the plugs while I was at it....got plugs from auto store cross reference to ngk they said it was the same heat range and I check electrod  length with calipers ,same...tracter started right up and ran great for about 10 min. And started back firing and quit.....going to check it out tonite anybody have an idea?    
  • Create New...