Jump to content

Slow C-160 restore

Sign in to follow this  
  • entry
    1
  • comments
    4
  • views
    181

slow C-160 restore

BAM1

326 views

Once again I'm returning to the well of knowledge you folks have. The Spring that returns the brake pedal on my C-160 broke some time ago, now I'm going thru and fixing all the little items this one has come up. Can any one give me a part number and a picture of this spring, and a location this spring goes, I've look and just don't see where it hooks to the pedal or an anchor point. 

IMG_5255.jpg



4 Comments


Recommended Comments

Slimpickins

Posted

I dont have pics but the spring goes under the console plate bottom left hooks to tiny bolt. Alot of pepole move it to hook on the rod before it enters the console and the other end just hooks in a hole back a little. (Because it is a pain in side) tension to how you like, Someone  thats better at the pics link thing should come along and help. Mines tore down right now.

Share this comment


Link to comment
Slimpickins

Posted

Found one but grainy  lower left if its the same as my 16 auto

image.jpeg

Share this comment


Link to comment
BAM1

Posted

Hey C-160 Automatic owners, Can some one post pictures of the correct routing of the hoses. I took mine apart and just want to make sure I'm putting them back in the correct ports on the valve. I really don't want to blow any thing apart.

 

Share this comment


Link to comment
BAM1

Posted (edited)

Well I did some looking and found the hoses run both ways so I went ahead and put them on, I hope it doesn't matter which way they go. Another piece of the puzzle done, move to next piece to fix.

 

Hoses before.jpg

Hoses after.jpg

Edited by BAM1

Share this comment


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...