Jump to content
Fin_

C-125 Won't Fire

Recommended Posts

Before it broke it got cross-threaded so we bought a helicoil kit and did that, and it worked fine. Now we found that when we sprayed the fuel starter it seemed to seep out of the helicoil type bush that attaches onto the spark plug.

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Fin_ said:

Before it broke it got cross-threaded so we bought a helicoil kit and did that, and it worked fine. Now we found that when we sprayed the fuel starter it seemed to seep out of the helicoil type bush that attaches onto the spark plug.

Did you use high temp RTV as mentioned in the helicoil instructions? I do not know if you can remove a helicoil and put in a new one.  may need to consider a new head.

 

Guess loctite at this point won't hurt.  Does fuel spur out of the pump out put while you crank?

Edited by pfrederi
  • Like 1

Share this post


Link to post
Share on other sites

I will check if the fuel spurs out tomorrow.

Share this post


Link to post
Share on other sites

Fuel spurs out of the pump. I started it and it went for a good minute but I had to balance the choke constantly and it was just throwing white smoke out everywhere, you could barely see anything. Also there was some type of liquid running out of the exhaust and carb which I pretty sure was fuel. 

Share this post


Link to post
Share on other sites

Tried again but just turns over and doesn't fire.

Share this post


Link to post
Share on other sites
Posted (edited)

You mite want to consider getting somebody to come over and give you a hand. 

Edited by Searcher60

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By dhr5050
      I am looking for an engine that will easily swap into my C100 that is not the K241AS. Any suggestions?
    • By D250power
      Hi I am looking for a distributor drive gear for the Renault 800  on the d250.  Also a cylinder head. I lost the gear.
    • By Rob R
      Hi folks Brewster Rob here, was gifted a Cub Cadet LTX 1040 in great shape other then a completely blown 19HP in-famous Kohler Courage SV590, today I acquired a 17HP Pro OHV CV490S in perfect running condition.... so I want to swap the engines. They have identical vertical shafts question is the electrical. The Courage had four wires coming from the engine red/green/white/purple, the Pro has 3 white, 1blk and 1 red.  I also have the alternator and regulator from the blown Courage.... might I be able to swap alternators???  I of course have the old Courage key switch I do NOT have the new engine key switch.........  Need help from the Red Square wizards and PLEASE think about the best result way to go here.... thank you in advance. 
    • By MAD MARK
      Bought this 310-8 for $100 came with a plow but no engine. Just want to put in the cheap HF $99 Predator 6.5hp. Searched on here and found that people have done this but I cant really find any information on what they needed to do to get it to work. Looks like about a 2" engine plate since the height of the PTOs are different and the mounting bolt locations are different. Besides that, any more tips or pointers?
       
      Just making this into a cheap plow tractor, I saw the linkage below the 310-8 is not like below my 312-8. It does not have a chain lift and just a straight bar. I mounted the blade to my 312-8 and it worked fine. Guessing the bar is so I can push down on the blade if need be? Is this something included in the plow package I missed before? Any insight there?
       
       


    • By BigMan-TinyTractor
      ,Hi all...
       
      I bought a D-250 a while back and I really like it but she's got a couple ghost problems that I can't seem to wrap my head around.
       
      I believe that it's a '76. It has the Renault engine in it.
       
      So three different times now... I've hit a small stump, stopping the mower dead in it's tracks. All three episodes were moderately violent. In two of the occasions, it stalled the mower after I disengaged the deck and backed off of the stump.
       
      So here's where it gets weird.
       
      After each incident, the mower would no longer start.  If I pulled the choke all the way on, it'd fire up and rev to the sky... Like sketchy high rpms which all three times was the only way I could limp it back to the barn.
       
      After completing cooling down and tweaking the fuel mixture screw back and forth, I've been able to get it to run well again...
       
      Sometimes I can ease the choke off and the governor goes crazy surging off and on... But in most cases, it simply won't run with the choke off.
       
      So what in the heck does this have to do with the impacts?
       
      The only theory I currently have is that it jolts the fuel tank and fuel filter badly enough to shake up some contamination... But that's just a wild guess. It's also definitely temperature related, because I can mess with carb settings enough to fix it so long as it isn't up to temperature yet.
       
      So there it is... Any of you guys ever heard of a crash related fuel issue?
       
      I feel like I'm going crazy. I know I'm missing something here in the troubleshooting.
       
      Thanks a bunch!
       
      Jacob
×