Jump to content
kawimaniac2145

onan p220g engine

Recommended Posts

kawimaniac2145

image.jpg

image.jpg

image.jpg

image.jpg

image.jpg

Share this post


Link to post
Share on other sites
 
 
kawimaniac2145

This is after I get it running good any other help would be appreciated thanks guys. Ps it was only running on one cylinder

Share this post


Link to post
Share on other sites
 
 
lynnmor

The fuel pump appears to be factory.

 

You need to get the rubber gasket around the oil filter to prevent cooling air from being lost.

 

Replace the rotten crankcase ventilation hose to keep dirt out of the engine.

 

Replace the bad vacuum and fuel lines.

 

Move the choke cable below the clamp screw to align it with the linkage.

 

I have no idea what you are using a vacuum pump for.

 

After hearing the surging, I believe that you lost the welch plug out of the carburetor on the muffler side.  Either it is lost or it needs to be removed and then cleaned behind it.  A 3/8" aluminum welch plug may be available at NAPA, always use a new one.

 

 

Share this post


Link to post
Share on other sites
 
kawimaniac2145

Well that welsh plug because in the surging. Because now it’s surging at high rpm and won’t stop And there’s fuel in the carburetor bowl

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...