Jump to content
Toasty

C-175 Automatic Idle Pulley issue

Recommended Posts

Toasty

A few years ago I had purchased two Wheel horses.  I am trying to get one of them put back together to put in use which is a 1980 C-175 Automatic.  The engine run, and I have tested the hydrostat and hydrolic lift and all that is working properly.  From what I can gather I am putting the idle pulley together wrong from what I can tell and was wondering if anyone on here has a picture of the C-175 Automatic with the belt cover off that show the idle pulley to help me out.  I have the break down sheet but a picture of a tractor put together would help out greatly.

 

Thanks

Share this post


Link to post
Share on other sites
 
Lee1977

I can't help you with a picture as I don't have a hydro. It's a flat idler that  runs on top of the belt the center hole is the idler shaft the goes through the back hole in the frame.  The bottom curved goes to the rear of the tractor and the brake shaft attaches to the bottom. There is also a spring that pulls the idler down.

 

Give us a picture and I'm sure we can help you get it right.

Edited by Lee1977

Share this post


Link to post
Share on other sites
 
Toasty

I figured out that the handle to release the idler pulley was not the correct one.  I now have it all back together now.

  • Like 1

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×