Jump to content

520H overcharging and not turning over

Recommended Posts

I'll check out the wiring on my other 520 and get back to you.

I have it wired wrong. When I get home I'll get it right. Let you know the result in a few days

Edited by 608KEB

Share this post

Link to post
Share on other sites

I used 1 10 ohm resistor. The volt meter is reading about 14 1/4 with the throttle wide open. I tired the meter with two 10ohm resistor's. It was reading about 16 volts with throttle open. I think the problem is solved.

Share this post

Link to post
Share on other sites

The end game here is to get the voltmeter to match your multimeter. If you need to fine tune the voltmeter, you will need additional resistor values such as 1, 3.3 or 4.7 ohms to add in series with your current "trimmer" resistor.


Well done.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By mustangken
      My 520H blow out a valve seat.  Any suggestions on a new motor or should I have the seat repaired?
    • By 608KEB
      Is this the correct setting to test the battery or voltage output? I tested four different batteries. The reading is saying about 17.0-17.5 on all 4 batteries.
    • By Dave54000
      Hello new to the forum I just bought a 1997 520h with 387 hrs  has a snowblower single stage and mower deck its in real good shape  i think it just needs a little maintaince.  Engine surges hopefully just needs a carb and tank cleaning. Headlights don t work and need to replace a idler sprocket on blower and possible have to replace the lift seal because the snowblower won't stay up it slowly lowers not sure if that's normal because if weight or needs to be fixed. Overall very happy I bought it  I grew up using my father's 520h 

    • By r1jakecfd
      Hi Guys,
      The Onan in my 520H was running poorly so last month I took the heads off, decarboned, cleaned/reseated the valves, checked valve seats and reassembled with new gasket set. When installing intake manifold, I realized last year (carb cleaning) I forgot to hook up vacuum line from manifold to gauge. Hooked it up correctly this time and ran great. First blizzard yesterday and started snow blowing. After about 15 minutes the became noticeably louder with less power.
      I was wondering firstly if anyone has any idea what went wrong?
      Also, I was thinking about repowering with a Honda or Vanguard and would love opinions on which way to go? Also, should I go with an engine or kit and which company? I’m good at fabrication, etc.
      Thanks in advance!
      Happy NewYear
    • By 608KEB
      I recently purchased a Original Cab model P6500CC01. Minus the roof.I was told by Original Cab that the glass windshield and ABS roof that they sell would not work on my cab. Has anyone modified a new roof and glass windshield to work on this cab? Or does someone know where I might find a used roof and glass windshield for this cab.