Jump to content
isd

missing throttle linkage parts ???

Recommended Posts

isd

Trying to restore this B-80 purchased as a basket case so never saw how this was hooked up.   Engine is rebuilt at a shop in town.  As pictured it starts right up, governor won't let it idle.   Before starting the governor is pulling the carb throttle wide open, when it starts it goes to about half throttle.   If I pull counter clockwise on the long arm on the governor round piece, it accelerates.    To me it seems that the wire connecting the governor to the carb should be longer, or there shold be a throttle return spring.    I also don't have (one is on order) the 42 cable to connect to the dash lever, but that seems to only be to accelerate.   It seems to me as it sits (with no cable connected) it should idle fine.   If I push the throttle lever on the carb toward the adjustment screw it idles odwn fine, but the governor doesn't let that happen.   What am i missing?   Right now , I have the governor arm  shaft CCW and the arm AWAY from the carb then tighten the 1/4 bolt.   

 

WHen the cable arrives, where does it connect?   My guess is right in front of the little arm, with the housing attached to the hole furthest to the left.

IMG_4654.JPG

  • Like 1

Share this post


Link to post
Share on other sites
 
ebinmaine

@OldWorkHorse maybe could get you a pic or two. He'll be busy as all get out for a day or three. 

 

 

  • Like 1

Share this post


Link to post
Share on other sites
 
OldWorkHorse

@isdI can surly grab a few pics tomorrow if this hasn't been answered for you by then!

Share this post


Link to post
Share on other sites
 
oldredrider

@isd you are correct as far as the cable mounting. 

To get your idle down, loosen the governor shaft bolt slightly; the 3/4" brass bolt. Rotate the disc clockwise to lessen spring tension on the governor arm so there is no spring pressure on the linkage. Tighten the brass bolt and see if that does the trick. 

  • Like 1

Share this post


Link to post
Share on other sites
 
Gregor

This is the governor on my 8hp Genny on the 876. My disc does not have that tab. Does that tab have a hole in it for the control cable? Mine seems to work ok.

20210722_072704.jpg.700d909b4973396d67d40b8952ea52b4.jpg20210722_072716.jpg.29ae9adf634ab8f0f19d0763a709c197.jpg20210722_073018.jpg.3391e40546e32b0d9e527432295d7a17.jpg

  • Like 1

Share this post


Link to post
Share on other sites
 
WHX??

:WRS: isd... always use another cheesehead! 

Here's a manual for that motor ... check out page 7.

The other manual has gov adjust on 5.1

 

That motor way too clean @Gregor ...I best come get it..... :ph34r:

Kohler K181S-30108d OM IPL SM (1).pdf Engine Kohler K91 K141 K161 K181 K241 K301 K321 SM 1972.pdf

Share this post


Link to post
Share on other sites
 
Gregor

That's the trouble with these Kohler motors. There seems to be sooooo many governor set up, for the same engine, it's hard for me to keep track.

 

I forgot I had this motor. Another 8hp Kohler. It was originally green, I'm guessing it came from a brand X Tractor. It isn't mounted on anything right now, so there is no control cable. It seems to be a bit more like yours. I have had it mounted on my 656, and my 876 temporarily.

20210403_113758.jpg.4640c0f3fc01349a90498754ed88fae6.jpg

20210722_085545.jpg.929c3829938c5ae05d3c9e296afbe7a1.jpg

20210722_085647.jpg.ebfa2397fe1a9017f937c2a3ddcf55c8.jpg

 

1 hour ago, WHX24 said:

That motor way too clean @Gregor ...I best come get it..... 

That's a problem with all my motors. My tractors only get ran long enough to take them from storage to my garage, and then back again. 2 minutes tops. I know that's not good for them, but I really have no place to go. I did take one of my tractors on a 1/2 mmile ride yesterday, that was fun.

Share this post


Link to post
Share on other sites
 
 
isd

Thanks for all the responses.    I think I have plenty of good ideas to try now.  I will update when it is working well.

Dan

 

 

Share this post


Link to post
Share on other sites
 
gwest_ca
5 hours ago, Gregor said:

I wish I knew how to save those files. :confusion-confused:

Download and "save as ......" Click on the manual pictures in the links below.

 

Share this post


Link to post
Share on other sites
 
Gregor
Posted (edited)

I figured out a way. I simply printed them off, and put them in a book. I can always find a book. :thumbs: Even when I save them, I don't know where I saved them to.  Duh  Guess what? There is a file called "Downloads" I may figure this out yet.

Edited by Gregor
  • Haha 1

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...