Jump to content
cafoose

Success finally got my 520-HC fixed

Recommended Posts

I finally got my ignition problem fixed on my 520-HC :banana-wrench::greetings-clappingyellow::banana-rock:I replaced the coil when the secondary resistance was not within specs which made it run better but still not starting when hot. Then I replaced the module today and left it run for at least ten minutes and it started numerous times with no problem :happy-partydance::dance::banana-jumprope:A big :thanks:  to everyone who helped me with this project!

20170517_130637.mp4

20170516_120825.jpg

20170516_120838.jpg

20170516_122136.jpg

20170516_122155.jpg

  • Like 5

Share this post


Link to post
Share on other sites

Hope you cleaned all that oil/dust residue while you had it tore down, those Onans like to be clean, Jeff.

  • Like 3

Share this post


Link to post
Share on other sites

Sounds great! I'm sure, as the WVHillbilly notes," those Onans like to be clean, Jeff."

 

Otherwise, love my '90 520-8. Grandson's legs a littlle short but he'll grow. :handgestures-thumbupright:

 

56ac1eb976772_520Wagon2.thumb.jpg.900d400ef13b3fa586158803f9b19f3e.jpg

  • Like 3

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×