Jump to content

My Onan doesn't have spark.......

Recommended Posts

Hey folks hope you can help. I'm pulling my hair out. I have a D160 that was retrofitted with a P220 previous to me purchasing it. I used it all this spring and summer but left it unused this fall for 6 to 8 weeks until the other day. It always started right up in the past. This time I couldn't get it to start it tried a couple times but then it would just roll over and over. I pulled the plugs and they were wet and full of soot. I cleaned them up and tried again with no luck. So I dug around and found all the service manual for trouble shooting the P220 Onan. The coil has the appropriate resistance of around 3 ohm primary from + to -  and 19K ohms between the secondaries. The control module goes from battery voltage to about 1 volt once per full revolution. I replaced the plugs with brand new and still no spark. I also hot wired the + side of coil from the battery with no change. 


 I'm out of ideas.and the winter snows are approaching fast.. 

Share this post

Link to post
Share on other sites
Posted (edited)

I fixed it inspite you helpful folks around here....it was the coil in spite of it testing as it should...

Edited by NOSValves

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.