Jump to content
Fin_

C-125 Won't Fire

Recommended Posts

Fin_

Before it broke it got cross-threaded so we bought a helicoil kit and did that, and it worked fine. Now we found that when we sprayed the fuel starter it seemed to seep out of the helicoil type bush that attaches onto the spark plug.

Share this post


Link to post
Share on other sites
 
pfrederi
1 hour ago, Fin_ said:

Before it broke it got cross-threaded so we bought a helicoil kit and did that, and it worked fine. Now we found that when we sprayed the fuel starter it seemed to seep out of the helicoil type bush that attaches onto the spark plug.

Did you use high temp RTV as mentioned in the helicoil instructions? I do not know if you can remove a helicoil and put in a new one.  may need to consider a new head.

 

Guess loctite at this point won't hurt.  Does fuel spur out of the pump out put while you crank?

Edited by pfrederi
  • Like 1

Share this post


Link to post
Share on other sites
 
Fin_

I will check if the fuel spurs out tomorrow.

Share this post


Link to post
Share on other sites
 
Fin_

Fuel spurs out of the pump. I started it and it went for a good minute but I had to balance the choke constantly and it was just throwing white smoke out everywhere, you could barely see anything. Also there was some type of liquid running out of the exhaust and carb which I pretty sure was fuel. 

Share this post


Link to post
Share on other sites
 
Fin_

Tried again but just turns over and doesn't fire.

Share this post


Link to post
Share on other sites
 
Searcher60

You mite want to consider getting somebody to come over and give you a hand. 

Edited by Searcher60

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • cJ_3D
      By cJ_3D
      Hey all!
       
      Replacing the drive belt on my 252-h. Anyone know the torque specification for the center screw when I put this pto clutch back on? I know it was on there tight it took a minute for the impact to break it loose. Thanks!
       
      CJ

    • bkarp@roadrunner.com
      By bkarp@roadrunner.com
      my magnum 12 kohler all of a sudden is blowing oil out of the carb. if rings are bad should oil be blowing out of the muffler.thanks for any help brent
    • Tinman1962
      By Tinman1962
      Recently got hold of a 656 it's has a "newer" 61/2 Briggs on it I don't believe that's right any ideas about that
    • Little Red Horse
      By Little Red Horse
      Hey all. I have a Electro 12 with a factory belly blade. It runs* and drives. I had used it to grade my driveway the last 6 yrs. Having moved I'm looking at my options on storing it or selling it. Frankly I have no idea what it is worth. I watched "ISaveTractors" video on 5 things to do with a new to you wheel horse/12hp kohler. (When i got it 6yrs ago) And went thru and did the adjustments and replaced the parts mentioned. It has been a good strong tractor for me until around July of this year. (2023)
      *Around July it started dying after running 20-30min. I replaced the carb (Chinese Amazon purchase) with one from isavetractors web site. That seemed to help it idle smoother(the old carbs jets wouldnt adjust), but it still dies at around 20-30min.
      So I've got 2 questions. 
      1. What is it worth? (As-Is) and
      2. What do I need to do to fix it? 
      Thanks yall!

    • 850ford
      By 850ford
      I am looking for a replacement Kohler for a 1980 c165,it is cradle mounted.
      Will a standard mount Kohler work, if I remove the cradle?
       I am located in Massachusetts 
        Thanks
×
×
  • Create New...