Jump to content
Sign in to follow this  
TLWheelHorse

Help! Maintenance on B-80

Recommended Posts

Hi, When you painted the engine did you paint over your grounds? The mounting plate for the coil and condenser needs to ground to the block I'm pretty sure. Make sure you have a good ground all the way back to the battery.

Share this post


Link to post
Share on other sites

Funny thing those B-80's, my friend has one and here is the funny thing, like my 1276, it will not spark until you let OFF the key, it will do nothing but turn over when held at the start position, funny I know but it is wierd, but it is how it is.

Share this post


Link to post
Share on other sites

Finally ordered a new key switch... Same thing! Still will not start.

Almost everything is new minus the coil wire! I am going to get a new battery today, the old one would barely turn the engine over.

Share this post


Link to post
Share on other sites

Ok guys... i got this back together last summer, did all the maintenance and it would not start!! It killed the battery...

I got frustrated with it, and am just now trying to figure out the problem (i have TONS of other projects that i have been working on).

Adjusted Carb

New Points (adjusted to .02)

New Coil

New Condensor

New Spark PLug

It just turns over and nothing... I was reading that it might be the ignition switch??

Points should be set at .019 if you set them at .02 it aint never going to start

what part of the world do you live in maybe theres some one near you that can help but its not in you profile

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×