Jump to content
  • ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoticons maximum are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By sfjohnson722
      Greetings all, first post to this forum.
      I am in the process of getting my father's 1971 Bronco 14 (1 0421 6) up and running. After pulling the hydrogear for reworking, I noticed some lash between the rear wheels when on jackstands. I found one of the hubs to be badly worn, but also noticed there seems to be a clicking or ratcheting when turning one side at a time (whether the parking brake is on or off). The opposite wheel does turn in the opposite direction - it just does so with a click / ratchet feel. I was expecting something smoother like with an automobile differential. Is this normal? Should I plan to split the case, and if so what should I be looking for?
      Thanks in advance for any information!
    • By elliot ness
       Cleaned up another old Simpsom loader laying around and mounted it on a 520H . I think it came out looking good. I have had at least 6 of these Simpson loader and I think they are great. all new fittings and hoses and stripped to bare metal, and painted, 125 lbs. of rear wts on each wheel, need to clean up bucket yet. It lift at least 7 ft. Love the 520's for loader tractors, easy steering and plenty of power.



























    • By 608KEB
      520H is dead. Things I've tested so far. I've jumped a wire from + battery to blue wire on starter. It cranks over good. I cleaned safety switches, starter, ignition connections. I notice if I jiggle or slowly turn key the lighted board will come on. A couple of times the tachometer reset itself.
       the lights will not turn on. Is it possibly the ignition switch?

    • By Guzzler
      I'm looking for a 42" rear discharge deck for my 300 series.  Looking for something that's in decent shape for $200.  Would pickup in MA, southern NH, or southern ME.
×