Jump to content

Recommended Posts

520H is dead. Things I've tested so far. I've jumped a wire from + battery to blue wire on starter. It cranks over good. I cleaned safety switches, starter, ignition connections. I notice if I jiggle or slowly turn key the lighted board will come on. A couple of times the tachometer reset itself.

 the lights will not turn on. Is it possibly the ignition switch?

IMG_20170926_171207933.jpg

Edited by 608KEB

Share this post


Link to post
Share on other sites

Molex plug! 

 

59cadcabdb0d4_plugairlines001.JPG.2106a6c24a3d962a2c3f48357bb24791.JPG

 

59cadcb5179c0_plugairlines004.JPG.bc64a671ea7b8edfa301860bd333a03f.JPG

  • Like 4

Share this post


Link to post
Share on other sites
49 minutes ago, squonk said:

Molex plug! 

 

59cadcabdb0d4_plugairlines001.JPG.2106a6c24a3d962a2c3f48357bb24791.JPG

 

59cadcb5179c0_plugairlines004.JPG.bc64a671ea7b8edfa301860bd333a03f.JPG

:text-yeahthat:

 

  • Like 1

Share this post


Link to post
Share on other sites

Could be corroded terminals in the plug that connects to the ignition switch.

  • Like 1

Share this post


Link to post
Share on other sites

I don't think it's the molex plug. I cleaned that pretty decent last winter. I had to bypass 1 of the 9 connectors. I'll try a ignition  switch. It's really corroded. I also did some soldering and heat shrinking to the 3 fuse holder last winter. I'll report

back my findings.

Share this post


Link to post
Share on other sites

Where can I pick up a 5 prong key switch locally?  Napa?

Share this post


Link to post
Share on other sites
6 hours ago, 608KEB said:

Where can I pick up a 5 prong key switch locally?  Napa?

Yes. The 103990 is very popular.

 

Garry

  • Like 3

Share this post


Link to post
Share on other sites

9 pin connector was the problem!:wacko:IMG_20170928_083347910.jpg

Edited by 608KEB
  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By kramermanusa
      NOS, Original Tractor Co snow cab
      Original Tractor Cab P650CC01 
       
      *NOTE: as far as I can tell, the plastic white top is all that is missing
      Otherwise, the pieces are in good shape, never used - just dirty from sitting.  The instructions and unopened original hardware also included.  Per the instructions this model is for 1990 and up 500 series tractors, although likely will fit / adapt to others somewhat easily.
       
      I bought this with my 520h from the original owner who advised it was never used and from the condition and packaging that appears to be the case.  I will not use it so I am looking to give a good home.  As a side note - the tractor only has 256 hours on it and also has a powered leaf / grass bagger unit (which is not something I see often as far as attachments).  But up for sale here is the NOS snow cab and hardware only
       

      .
    • By 608KEB
      I changed the oil/filter on my 520H last fall. I only put 4 hours in the tractor last winter. The oil is still golden-brown in color. It's looks new  Should I change the oil and filter again?

    • By chucksterock
      Been watching Craigslist and found this listing:
       
       
      Anyone see any red flags?  things to ask?  thanks!
    • By elliot ness
       Cleaned up another old Simpsom loader laying around and mounted it on a 520H . I think it came out looking good. I have had at least 6 of these Simpson loader and I think they are great. all new fittings and hoses and stripped to bare metal, and painted, 125 lbs. of rear wts on each wheel, need to clean up bucket yet. It lift at least 7 ft. Love the 520's for loader tractors, easy steering and plenty of power.



























    • By Dave 520h
      I'm looking for a rear axle for my 520h.  Anybody have one?  I have a loader on the tractor and this is the second time I broke the axle.  I would consider a complete rear end.
×