Jump to content

Recommended Posts

520H is dead. Things I've tested so far. I've jumped a wire from + battery to blue wire on starter. It cranks over good. I cleaned safety switches, starter, ignition connections. I notice if I jiggle or slowly turn key the lighted board will come on. A couple of times the tachometer reset itself.

 the lights will not turn on. Is it possibly the ignition switch?

IMG_20170926_171207933.jpg

Edited by 608KEB

Share this post


Link to post
Share on other sites

Molex plug! 

 

59cadcabdb0d4_plugairlines001.JPG.2106a6c24a3d962a2c3f48357bb24791.JPG

 

59cadcb5179c0_plugairlines004.JPG.bc64a671ea7b8edfa301860bd333a03f.JPG

  • Like 4

Share this post


Link to post
Share on other sites
49 minutes ago, squonk said:

Molex plug! 

 

59cadcabdb0d4_plugairlines001.JPG.2106a6c24a3d962a2c3f48357bb24791.JPG

 

59cadcb5179c0_plugairlines004.JPG.bc64a671ea7b8edfa301860bd333a03f.JPG

:text-yeahthat:

 

  • Like 1

Share this post


Link to post
Share on other sites

Could be corroded terminals in the plug that connects to the ignition switch.

  • Like 1

Share this post


Link to post
Share on other sites

I don't think it's the molex plug. I cleaned that pretty decent last winter. I had to bypass 1 of the 9 connectors. I'll try a ignition  switch. It's really corroded. I also did some soldering and heat shrinking to the 3 fuse holder last winter. I'll report

back my findings.

Share this post


Link to post
Share on other sites

Where can I pick up a 5 prong key switch locally?  Napa?

Share this post


Link to post
Share on other sites
6 hours ago, 608KEB said:

Where can I pick up a 5 prong key switch locally?  Napa?

Yes. The 103990 is very popular.

 

Garry

  • Like 3

Share this post


Link to post
Share on other sites

9 pin connector was the problem!:wacko:IMG_20170928_083347910.jpg

Edited by 608KEB
  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By elliot ness
       Cleaned up another old Simpsom loader laying around and mounted it on a 520H . I think it came out looking good. I have had at least 6 of these Simpson loader and I think they are great. all new fittings and hoses and stripped to bare metal, and painted, 125 lbs. of rear wts on each wheel, need to clean up bucket yet. It lift at least 7 ft. Love the 520's for loader tractors, easy steering and plenty of power.



























    • By Dave 520h
      I'm looking for a rear axle for my 520h.  Anybody have one?  I have a loader on the tractor and this is the second time I broke the axle.  I would consider a complete rear end.
    • By Heavy Duty
      48" side discharge mower deck, used only 1 summer. This deck is in fantastic shape. Little bit of rust, very straight and spins like new. I can ship Fastenal at cost, or pick up. 300.00 OBO. https://flic.kr/p/X6JGCv
      https://flic.kr/p/W2Kf91
      https://flic.kr/p/XeMMYG
    • By AlexD
      I have a 1994 520H that was running good and lost spark.  Comes with a snow cab but no other attachments.  I would like to find someone that want to get it back running and use it.
       
      Willing to give to a good home not looking to get anything for it.
       
      Alex
×