Jump to content

Recommended Posts

on my 953 hasn't been run since 2011 and so when I first started it smoked like heck then thinned out to a almost whitish color which goes back and fourth to light blue to the whitish color what do you think is going on in there? fresh 93 octane fuel , oil has been changed 30W so is it rebuild time?

Share this post


Link to post
Share on other sites

I would run some Seafoam first. Maybe MMO in the oil.

Share this post


Link to post
Share on other sites

MMO= Marvel mystery oil. You probably have stuck or sticking rings. You can add MMO to both gas and crank case.

Get you some!

  • Like 3

Share this post


Link to post
Share on other sites

10-4 on the marvel mystery oil .....I've heard great things about it, my grand father swore by it but I never tried it ok I will have to get me some now I have one other question to do a compression test on this i'm told you got to run the engine in reverse to avoid the auto compression release? to get a accurate reading

Share this post


Link to post
Share on other sites

Leak down tests are more revealing.  Valves vs rings.

  • Like 1

Share this post


Link to post
Share on other sites

ok well I 've never heard of a leak down test ..................if you could shed some light on this that would be great!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×