Jump to content

Recommended Posts

Whoever suggested that my power issue was due to a broken accelerator spring, you were right on! Thank heavens for all the suggestions I got for where to source parts, too. I am into my repair and found the spring broken and the valve seat sleeve badly chewed up. I can order a replacement sleeve from Jacks Small Engine (done) and will have this fixed up in a jiffy.

 

 

IMG_7284.JPG

IMG_7286.JPG

IMG_7287.JPG

  • Like 5

Share this post


Link to post
Share on other sites

:woohoo:           Glad you are on your way to getting it back in action, a bit of a PITA to get to but this repair should do the trick. Where did you end up finding the springs?

  • Like 1

Share this post


Link to post
Share on other sites

Tractor all back together and driving like a champ! Unfortunately, the magnetic clutch stopped working now.... not sure why. Something else to look into.

Share this post


Link to post
Share on other sites
1 hour ago, FatJackDurham said:

clutch stopped working now

Fuse?

 

On 7/23/2017 at 9:10 PM, FatJackDurham said:

Refracman tipped me off to a guy that had some made.

He hooked me up too, about five years back.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, 953 nut said:

Fuse?

 

He hooked me up too, about five years back.

 

I'll check with him. No, I jumpers the battery directly to the clutch and no click. I'll check the wiring tomorrow on it it I get a chance.

Share this post


Link to post
Share on other sites

Check out this thread on the clutches.

 

Share this post


Link to post
Share on other sites

I have some of these hydrogear parts salvaged from units that had bad motors & I scrapped. Valves & springs & other small pieces, not too sure what now. Would have to look.

Share this post


Link to post
Share on other sites

It's OK everyone, Turned out the problem was that one of the "tabs" in the connector had come out. It was loose, but when held in place during the connection, the clutch works!

 

The tractor is good to go, and will do a little mowing next week.

 

I have gone from two useless tractors, to two fully operational, if somewhat dangerous, ones. Neither at this time has what I would call a usable parking brake. But, who cares!!!! They both GO! Why would I want to STOP?!?!????

 

Wheel Horses.JPG

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, FatJackDurham said:

the clutch works!

:woohoo:

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×