Jump to content
Jess

518H 18HP Onan

Recommended Posts

You are a very patient and determined man! I don't think I could have stayed with it like you did for all this time. I learned a bunch just reading this and will know what to do when mine (and they will sooner or later) starts doing the same thing.  Thank you!     :handgestures-thumbupright: :handgestures-thumbupright:

  • Like 2

Share this post


Link to post
Share on other sites
Thank you,
Being the original owner of this tractor and the 30 +  years of use I hated to give up on it ! Like part of the family. This was one of the few things I moved with me when I relocated here to MO  from NY almost 20 years ago . I had a 3 acre lawn around my home there and it always did a great job and now I mow around 6 acres , but I break it up between my 3 Wheel Horses and other machines. Fun thing to do when retired . It has been a learning experience ! I was happy to have found this sight and the members to help me through this process .
    Jesse
  • Like 1

Share this post


Link to post
Share on other sites

Im having the same trouble with my 520. Im glad I read all the way through this tread. Im going to go with the rotor first thing., What part number did you use Jess?

  • Like 1

Share this post


Link to post
Share on other sites
I got it from an E=Bay seller ,Part # 166-0767  their e=bay item # is 301981659736  best price I could find $27.50 Free shipping and fast !  Seller e-bay name is (timsmobiletruckrepair )

s-l1600.jpg

  • Like 1

Share this post


Link to post
Share on other sites

Hi Jess, I did not get a chance to try out the Ignition rotor because the battery was dead and won't hold a charge, so I bought a new battery at Tractor Supply this afternoon, haven't installed it yet. However, the old ring was indeed a black one, and the magnets were weak, one of them was so weak that it wouldn't even hold a paper clip !!! The new gray ring magnets were plenty strong. Hopefully I will riding the range once again next week. Have a great weekend everyone, and Happy Father's Day to all dad's out there in Wheel Horse land.

  • Like 1

Share this post


Link to post
Share on other sites

 

Yea my battery was week also from messing with this dyeing problem for so long , so I put a new one in a couple of weeks few weeks ago when I started again this year . I know my original Black trigger ring / Rotor had 1 week magnet . I used my 518H today off and on for several hour again  in 90% heat and never missed a beat !  Still a great running machine ! 
 Happy Fathers Day to you and the team as well !
Edited by Jess
wording
  • Like 1

Share this post


Link to post
Share on other sites
20 hours ago, Jess said:
I got it from an E=Bay seller ,Part # 166-0767  their e=bay item # is 301981659736  best price I could find $27.50 Free shipping and fast !  Seller e-bay name is (timsmobiletruckrepair )

s-l1600.jpg

 Thanks jess

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

×