Jump to content
BOWTIE

BOUGHT A ROUGH 1976 C120 AUTO

Recommended Posts

JUST PICK UP A 1976 C120 AUTO TONIGHT 4 MILES FROM HOME. I GAVE A $100 FOR IT. PO SAID IT RUNS BUT NEEDS A FUEL PUMP. DECALS AND METAL TAG SAYS 76 C120 AUTO, BUT MOTOR TAG READS K341S AND IT DOES HAVE 10 HEAD BOLTS. WILL TRY TO GET IT RUNNING TOMORROW.HERE ARE SOME PICTURES FOR NOW MORE INFO LATER.

post-4576-0-87318700-1428540426_thumb.jp

post-4576-0-15773100-1428540432_thumb.jp

post-4576-0-62819500-1428540437_thumb.jp

post-4576-0-13222100-1428540442_thumb.jp

post-4576-0-79690800-1428540446_thumb.jp

post-4576-0-44041400-1428540451_thumb.jp

  • Like 5

Share this post


Link to post
Share on other sites

To me that looks like a deal for a hundred bucks!! And with a k341!!

Share this post


Link to post
Share on other sites

Great find....heck, the rear axle bracket is worth half of what ya paid!

Mike.........

Share this post


Link to post
Share on other sites

That is not just a deal that is a steal.  Looks like it will clean right up.

Share this post


Link to post
Share on other sites

                                                                 :woohoo:        You did good...real good.

Share this post


Link to post
Share on other sites

You call that rough?! Heck it's just showing you it ain't afraid to work! Nice grab

Share this post


Link to post
Share on other sites

Rough???? Man that looks better than half of my stuff! And a 16 jammed in at some point too!!!

 

I'll double your money---its a manual lift Hydro... just what I've been looking for!  :)

 

Tony

Share this post


Link to post
Share on other sites

Thats a Nice c120 and for 100 bucks steal. I got my 79 121 for free from my grandfather i wish it was that nice. Pictures of the restoration coming soon. nice Find

Share this post


Link to post
Share on other sites

I GAVE IT A PRESSURE WASH TODAY IN THE RAIN TODAY. THE ENGINE IS K341S SERIAL NUMBER MAKING IT A 1993. REMOVED THE FENDER,FRONT MULE,REAR MOUNTING BRACKET AND A BRAND HOUR METER THEY NEVER HOOKED UP. I WILL RINSE THE FUEL TANK TOMORROW,CLEAN CARB,PUT THE FUEL PUMP BACK ON AND TRY TO START IT. HAVE YOU GUYS NOTICED HOW THE TIE ROD NUTS COME LOOSE?

Edited by BOWTIE

Share this post


Link to post
Share on other sites

Nice find! Looks better than my C160. That will make you a great tractor

Share this post


Link to post
Share on other sites

Boy you can't beat that for 100 bucks! great find!

Share this post


Link to post
Share on other sites

THE OLD TRACTOR IS RUNNING NOW. CLEANED THE FUEL SYSTEM OUT PUT THE OLD FUEL PUMP BACK ON AND IT RUNS GREAT. THE CHARGING SYSTEM DIDN'T WORK. THE PROBLEM WAS THE WRONG IGNITION SWITCH. SOMEBODY PUT ONE IN IT FOR A MAGNETO IGNITION INSTEAD OF BATTERY/COIL/POINTS IGITION. NOW IT CHARGES AND LIGHTS WORK. I WISH THEY PUT PART NUMBERS ON THOSE SWITCHES,THEY WERE BOTH 5 TERMINAL. CHANGED MOTOR OIL AND PUT 1 QUART IN THE AUTOMATIC AND SEEMS TO WORK GREAT. I WILL MOUNT THE SEAT AND TAKE FOR A SPIN SOON.

  • Like 1

Share this post


Link to post
Share on other sites

...HAVE YOU GUYS NOTICED HOW THE TIE ROD NUTS COME LOOSE?

Are you asking why they come loose? The nuts should be 3/8-24 (fine thread) nylock nuts.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×