Jump to content
  • ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoticons maximum are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By r1jakecfd
      Hi Guys,
      I know my voltage regulator is bad on my Onan P220 and was wondering if anyone has an opinion on a replacement, OEM or aftermarket? 
      Also, I checked my stator leads for AC Voltage and got about 25 volts at 3600 rpm on each. Is this OK? I know it says in the 40’s.
      Thanks guys
    • By lodestonefarm
      I went out to use my 520H with blower this evening and it won't start.  I used this machine a few days ago (for the first time this winter).  The battery has been on a trickle charge so I don't think that's the problem.  It's done this before where it won't start, won't start, and then starts.  Usually that is in cold weather and after I've previously used it to blow snow.  I don't have a heated garage so I think it might have some ice somewhere that was introduced as water the last time I blew snow.
       
      Here's what it's currently doing.  When I turn the Ignition to 'On' the red warning lights and the dashs light all come on.  When I turn the key to start position I get a single 'Click' and nothing more.  I tried jumping it from a hot battery just to rule out a bad battery.  Same behavior.  Following some of the other threads about 520s with trouble starting, I pulled the blue wire off the starter solenoid.  If I run a jumper wire from the (+) side of the battery directly to the solenoid I get the same behavior (regardless of key being in on or off position)- small spark where my jumper wire is touching the battery terminal and a single click.  
       
      I'm unsure what this means about the solenoid and if that, in any way tests, the starter.  Could it be that my starter is bad/frozen?  I tried using a heat lamp to warm up that area, but in this weather (and my garage, which is really just a tarp shed) that just isn't going to work.  
       
      I've downloaded the demystification guide and started looking at it but I'm hoping someone might have some suggestions.  Snow is falling and I'm not making much headway on this.  
       
      Thanks
    • By Npostusa
      Hi Just bought my 312 this spring when we moved into a new home with two acres of land.  Love the wheel horse, but I am not even sure if I have to change a oil filter and for that matter where the filter or oil plug would be - any guidance would be appreciated.  Put a little marvel mystery oil in the gas, and just started it up for a few, but want to change the oil for the spring. Any guidance on where to start would be greatly appreciated. 

    • By lak1965
      Like many others on this site I decided Sunday it was time to install the New / Used Cab I bought in spring with the help of my brother. I never had it installed so was not sure what I was in for but it was assembled when I received it. First Picture was install rear frame under seat. It was at this point I went to RedSquare and downloaded the manual and printed it out for reference.

      Next install front of frame. Had to remove some brackets that mounted to the dash and drill a hole one each side of foot boards to mount the inside brace. That is a forward swept axle and tires you see sitting in the shed. Next spring project to mount that on the old C-160. Also I will change the way the lights are mounted on the hardtop.
       

      And finally the finished product. I was surprised at how well it fit and how easy it was to install. Let it Snow, Let it snow , Let it snow!

    • By Keith
      What other models can I use the upper steering shaft for my C-120?   
       
      Are there aftermarket steering wheels for this tractor?
×