Jump to content
Sign in to follow this  
MaineDad

C-160 Transmission Question

Recommended Posts

Check with this company, Micah:

B J HYDRAULICS

6590 S M 43 HWY

DELTON, MI

49046-9627

Phone: 269-623-5136

They fixed me up with a full gasket/seal kit for a 1973 14 Automatic quite a few years ago. (They are also good with Eatons. B) )

Share this post


Link to post
Share on other sites

That's odd......

The last three times I tried to access their site through that link, it took me to a "no longer there" page. B)

Share this post


Link to post
Share on other sites

I just picked up the gasket for the transmission and will try to get her running tonight. Will update later tonight. Wish me luck B)

Share this post


Link to post
Share on other sites

:horseplay: :banana: :horseplay:

I installed the tranny I bought on eBay from Joes Power and it worked great! The lift worked too!

I drove her around in the rain and boy does this go well. Only two problems though; the tow valve is so rusted that the slot for the screw driver crumbled into pieces when I tried to turn it. I have another one if I can ever get it out. Also the big 23x10.5x12 tires hit the outside of the tranny pump. I put the old tires back on and will look into some 23x8.5x12 tires soon.

But all in all I am happy. I'm glad I found this tranny...

Thanks guys!

Share this post


Link to post
Share on other sites

SO what are you going to use this one for?

You may well be better off with the narrower tires if you will need traction.

Congrats on getting the beast going B)

Share this post


Link to post
Share on other sites

Micah,

That's great - congratulations on getting it going. B)

Share this post


Link to post
Share on other sites

That's odd......

The last three times I tried to access their site through that link, it took me to a "no longer there" page. B)

TT, you've probably already resolved this, but if not, their actual URL is:

http://www.bjhydraulics.com/

I've had a few glitches in links (not usually on this site, though) lately - I think the internet is getting brain scrambled! :whistle:

Cheers!

Duff B)

Share this post


Link to post
Share on other sites

Micah:

This is an interseting thread since I have a C160 auto also. I have a hydro lift that will not operate but that is another story. I see by the photos that the direction lever spring mechanism is dirty. I would suggest since it is apart you clean, check, and adjust it if needed. The tractor will drift front or backward if the spring tension is out of adjustment.

Share this post


Link to post
Share on other sites

Oldiron - Yeah it was dirty. I did clean it up nice.

Charlie - I was lucky. I paid $100 plus shipping. Timing is everything, because I tried to bid on another one after that and it got up to $300!

Share this post


Link to post
Share on other sites

Well I took the pump motor apart and what a mess. There was a retaining ring that was mangled and broken in pieces. The bearing was a mess too. The needle bearings look fine. The spring on the motor shaft was bent to heck too.

So I will try to find replacement parts and rebuild this. A quick look on rcpw showed NLA on the ball bearing (200187) and the spring (200210). Any ideas on where to find these?

get it running yet

Share this post


Link to post
Share on other sites

im hving the same problem as discussed. got a used trans from a reliable source installed it and added with some difficulty the 5.5 quarts of 10w30 as prescribed. wheels will move just slightly but not much. am stuck at that any suggestions thanks in advance

Share this post


Link to post
Share on other sites

im hving the same problem as discussed. got a used trans from a reliable source installed it and added with some difficulty the 5.5 quarts of 10w30 as prescribed. wheels will move just slightly but not much. am stuck at that any suggestions thanks in advance

Is the release valve closed? I'm pretty sure the C-161 is a Sundstrand equipped machine. Its behind your left foot (if you were sitting on the tractor) and under the rear fender. Did you install a new filter? If not is the original filter an official WH filter? There is a NAPA and a WIX filter that work as well but I dont know the #'s for them. Just because a filter fits does not mean its correct for your tractor.

Mike..........

:WRS:

Share this post


Link to post
Share on other sites

yes installed a new filter will check the release valve had a heck of a time getting oil in the trans added the prescribed 5.5 quarts does this system need to be primed?

Share this post


Link to post
Share on other sites

wheni did my sundstand it self primed it self,didnt even have to crack a hose fitting to let let air out,if its working right they self prime

Share this post


Link to post
Share on other sites

thanks for the info really starting to supect that valve will try tonight

Share this post


Link to post
Share on other sites

the valve was the culprit but now the trans engages forward and goes backward so im assuming the set screws are the culprit on this one

Share this post


Link to post
Share on other sites

I have a question on the C-160 tranny? Is there suposed to be a cover plate on the back where the triangle is with 3 threaded holes are? My Bronco 14 has a plate bolted on but my C-160 does not.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×