Jump to content
Sign in to follow this  
SKC120

Stephen from Scotland

Recommended Posts

Hello there,

I'm Stephen living in Aberdeenshire, Scotland.

Bought a C120 8 Speed at Christmas, had great fun plooin the snow for few days then had some starting issues. Eventually got them sorted and then started to play with the hydraulics / 3 point linkage (retro fiited by a smiddy I think) Got them working and fitted the plough. Wouldn't win any competions but managed to turn the ground over.(saved 3 days digging with the spade!!!!)

Next morning started her up and jumped on, no drive and strange noises coming from gear box, gears don't want to mesh. To cut a long story short, took the G/Box out and while trying to pull the hubs off broke one. Devastated :thumbs:

the plan now is to get a new box with hubs (anyone got one at a resonable price?),get her going and then have a look in the box latter.

Never new anything about :banghead: ' s before and am pleasantly surprised the following they have. Only had her a month and I'm bitten.

Thanks for reading

Share this post


Link to post
Share on other sites

:banghead: yhis will help with what you need. plus we like pic's. :thumbs:

Share this post


Link to post
Share on other sites

Hi there,

even further north than me! :thumbs:

you should have no problem with people to help on here - you can get hubs and 8 speed trannies from fleabay. There are plenty of people on here with spares and the know how too.

Unfortunately the majority of horses and spares are in the south :ROTF: but at least we're on the same continent.

Hubs are a nightmare and need a custom puller making from a drop plate and then lots of heat!!! with hubs there seems to be two kinds - seized and floating (no matter how tight you tighten them) :banghead:

Gear box if its an 8 speed could by jus the selector fork for high/low, its a weak spot and can fail meaning the box has to be stripped.

If you are capable of taking the box off I would split it and just see if it's terminal (teeth missing) or a bent/broken selector.

mark

Share this post


Link to post
Share on other sites

:banghead: for everyones reply. Think I've managed to up load some photos.

I did think (hope) it might be the selector fork.

Might have a go at the hubs and box while I'm waiting for a box.

I'll let you know how I get on.

Latter

Share this post


Link to post
Share on other sites

welcome to euro horse stephen

sometimes its cheaper to but a whole tractor than just a part

at least you will have some other spare parts.

By the way the pics look great.

Your poor wife looks frozen

Share this post


Link to post
Share on other sites

Hi Steve, :banghead: Glad to have you on the Forum. I presume your ok for locating Toro Dealers in your Area and sourcing Manuals ?. If you need any help with finding them Let us know.

Regards

Share this post


Link to post
Share on other sites

Hello and :banghead:

Sure would like to see pics of your 3 point on the back.

Share this post


Link to post
Share on other sites

I'll post some more photos (3 point) once I get it back together

Later

Share this post


Link to post
Share on other sites

Hello Stephen and :thumbs: . If you need any help with the tranny let us know...manuals, etc. Not hard to fix, depending on what you find....take pictures. The hubs can be the worst part. :banghead:

Share this post


Link to post
Share on other sites

:thumbs:

Lots of great poeple all around the world willing to help! :banghead:

Share this post


Link to post
Share on other sites

:banghead: hey like to see pics of the three point and how is there hyrdrolics if its an 8 speed,aux hydro pump,and the tranny can be repaired,lots of guys here have redone them,i even did a few and had never done one before

Share this post


Link to post
Share on other sites

:banghead: hey like to see pics of the three point and how is there hyrdrolics if its an 8 speed,aux hydro pump,and the tranny can be repaired,lots of guys here have redone them,i even did a few and had never done one before

Hi there,

Check out photos of hydraulic pump set up on link. 3 point linkage off just now, will post photos when it's back together.

G/box is terminal without some spares. Can you still get them in the US?

Gears worn, cracked, teeth missing and needle bearings all over the place!!!!

Think I've sorced a box just waiting for confirmation.

But if I could get spares I'd would re-build it as a spare.

Later

Share this post


Link to post
Share on other sites

Hi Steve, :banghead: Glad to have you on the Forum. I presume your ok for locating Toro Dealers in your Area and sourcing Manuals ?. If you need any help with finding them Let us know.

Regards

Hi Steve, Have you checked for Local suppliers?.

Share this post


Link to post
Share on other sites

Hi Steve, :banghead: Glad to have you on the Forum. I presume your ok for locating Toro Dealers in your Area and sourcing Manuals ?. If you need any help with finding them Let us know.

Regards

Hi Steve, Have you checked for Local suppliers?.

Hi there,

I've spoke to my local dealer (not far away) and I'm going to see him next time I'm home.

Have you had any dealings with getting old spares through your dealer from the States?

Later

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×