Jump to content
Sign in to follow this  
Cleaverkid

'69 gt-14 hydro sprung a leak

Recommended Posts

Hi guys. I've only posted a couple of times on here but I sure do enjoy reading all of the beneficial help and looking at all of those really cool tractors. :D I'm a WH junkie at heart, but only have 2 horses myself right now, '64 864 w. 36RD mower and snowblade and '69 GT-14 w. 16hp Kohler and 48SD deck.

Was using the GT-14 last night to mow and apparently sprung a leak at some point. :USA: The tractor didn't exhibit any noticable symptoms during the 1 hour of mowing, but I discovered afterwards that I had left quarter size drops along the drive each time I drove on & off of it. Went back out to look at my baby and discovered a 6 in. puddle of ATF on the floor under the tranny. It appears that a hose that comes out the top, rear, left corner of the tranny and loops around the back then up toward the front on the right side is leaking at the connector on the side of the trans. Does anyone know if these hoses are readily available or am I going to need to have one custom built?

Also, before I start tearing into this willy-nilly, can someone give me some solid troubleshooting steps I should take to determine for sure what's going on first? Maybe I've already done what needs to be done, since I found this leak, but I've never torn into a hydro before so don't want to screw it up with ignorance.

Thanks, guys for being understanding and reading this long winded plea.

Joe in Fort Wayne, IN

Share this post


Link to post
Share on other sites

Can get a hose made pretty easy at a good hose shop,Rick

Share this post


Link to post
Share on other sites

Thanks, Rick! I appreciate the response.

Just took a gander at your gallery of pics...holy cow, dude...you've got a big herd! I'm impressed. Sure would love to walk through that building just looking at stuff. That would be as impressive to me as the entertainment over in Branson!

Share this post


Link to post
Share on other sites

Wouldn't you know. I blew the same exact hose. Of course it happened late Saturday after every one is closed on Memorial Day weekend. Guess I'll find out if any body stocks SAE 4 straight o-ring fittings on Tuesday. :D

Share this post


Link to post
Share on other sites

Thanks, Rick! I appreciate the response.

Just took a gander at your gallery of pics...holy cow, dude...you've got a big herd! I'm impressed. Sure would love to walk through that building just looking at stuff. That would be as impressive to me as the entertainment over in Branson!

Added two! :D Rick

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×