Jump to content
Save Old Iron

Indicator Lites

Recommended Posts

Will, getting close with the reverse engineering. I know you are correct about the voltage regulation being on the pc board. Still drawing it out.

please confirm this is the same sequence of display lamps you have on your tractor - meaning the top lamp is "seat switch" then "parking brake" then clutch pedal" , etc. The picture shows a 416-8.

just want to be sure - the demystification guide sequence is not the same (maybe no surprise there) but my tractor is a 1987 and there is no direct schematic available for an 87'. The 89 and up does not match my wiring - so on and so on.

displaylamparrangement.jpg

thanks :scratchead:

yup...thats the order, just verified

Share this post


Link to post
Share on other sites

Just curious, Have you considered etching a new board? All the stuff you need can be had from Radio Shack for less than $20. Transfer the components from the corroded board or splurge for new ones and you're good for a few more mouse nests,... er,... years.

Share this post


Link to post
Share on other sites

The copper traces are a mess and I would consider it a total loss other than the educational value to help others who will experience the same issues and not want to pay $160 + for the replacement pcboard.

corroded12voltbulbpower.jpg

missingcontatctpost.jpg

solderjointquality.jpg

Jim,

I have not etched a board in the last 25 years. I always wanted to try the photo-etch process.

I was a decent "wire wrapper" in my day and found it easier than etching. Now with the photo process and a good laser printer - I might give it a go. I might have to. Anyone know where I can get decent freebee schematic creation software? My reverse engineering sketch looks worse than that rat's nest in the hood tower !!

Truckin88,

I do have the indicator circuit mapped out for the parking brake and can give you pin by pin resistance measurements to take - I'll post these later today. I'm assuming you have the green coating completely removed from your circuit board since you said you had checked for corrosion and cracks. Just wanted to check.

HOWEVER, something as seemingly simple as the power to the IC chip has me baffled. I know there are folks out there who have an interest in electronics and I'll post a sketch later this morning for some advise. Maybe I'm missing something by not thinking 1970's design philosophy here - but let me recheck my traces before I post later.

Dkopp,

I found out the 54lsxx chips are military spec IC's with a larger temperature range than the standard 74xx series. Probably can't get the mil spec stuff but the chip is still available for 39 cents.

So back to the parts store .... my flux pen dried up :scratchead: my florescent magnified viewer broke a pot metal viewer mount :hide: my soldering iron tip is too big and seized to the iron :ychain: and this new lead free solder .. well... sucks :ychain:

guess now I better understand the frustration from the mechanical side of the hobby when folks can't get a steering wheel off the steering shaft - a seemingly simple task that turns into a battle royale :ychain:

  • Like 1

Share this post


Link to post
Share on other sites

Do a search for free pcb and you should see several come up on your search. Eagle layout editor is one. I'm not familiar with it but they do have some demo software. Not sure of the limitations though. PCB123 is another and freepcb is yet another. Not familiar with any of those either, just suggesting. Then you can also get a pspice package that has a pcb designer built-in. Cadence I think has that capability. I have been getting their freeware version for some years, but have not had alot of time to play with the thing. Again, not for sure what limitations there are on all those either. Wish I could be more help to you.

Have you thought about doing point-to-point wiring on a perfboard for the repair and using LEDs for the lights? I realize that you may be going for an original restore, but just asking. Have you found sources for all the repair parts yet?

Dan

Share this post


Link to post
Share on other sites

I've been looking for this sort of information since I bought my 312-8 back in the spring. I've posted on a different forum regarding Wheel Horse tractors but nobody was able to answer my questions.

Anyway, when I took apart my indicator board, I found out that it doesn't have any grain of wheat bulbs in it. Zero, nada. Do the bulbs just fall out over time? How do you reinstall these bulbs?

My indicator board appears to be in good condition (clean-ish at least, from what I remember). I'm not much of an electronics technician but I can be handy with a soldering iron. I'm interested in trying to get this aspect of my tractor functional again so it is in full working order (without replacing the unit, which is like a $140 piece from partstree.com).

:scratchead::hide: :ychain:

Share this post


Link to post
Share on other sites

geoff,

the red indicator caps on the dash of the tractor pull out of a rubber grommet - you should then be able to see the grain o wheat bulbs thru the holes in the dash.

if you have the display board out already, you should have 5 bulbs mounted in small rubber "bulb holder / sockets" - below is a picture of one of the holders with a bulb in it - next to it is one of the two posts the next holder will push down over.

The purple lines indicate how the bulb wires are bent thru the rubber body of the holder - as you mush the holder and bulb down over the connector posts, the rubber stretches and grabs the posts and compresses the bulb leads against the posts - the posts supply the ground and power to the bulbs.

lampholderwiring.jpg

so - you should have 5 rubber holders and 5 bulbs to get yourself going. If no rubber holders are to be had - you could solder the bulb leads directly to the posts - or use led's with a voltage dropping resistor - my board is in such poor shape I am considering buying 5 individual 12 volt indicator assemblies and fastening then directly to the dash - then hardwiring them to the posts.

the bulb resistance measures about 180 ohms on a good bulb - so I figure they would draw about 1/10th amp (100ma) each.

Keep the questions coming so I know how to benefit the most people with this post. I will be showing how to check the components on the board in the next day or two - how to check diode function - measure resistors and check transistor with an ohmmeter.

Tuckin88 - I have not forgotten you - I am 80% complete on the circuit reverse engineering and I understand 90% of it - just have to fiqure out how this sucker is actually powered from 12 volts to work a 5 volt IC chip.

I'll post a schematic for commentary in the next day or two.

  • Like 1

Share this post


Link to post
Share on other sites

First pass at understanding how the circuit board works - its only about 80% complete but shows a few things

416-8displaypcbschematiclarge.gif

the 12 pin connector in the upper left corner is the pc board connector

the logic chip consists of 4 identical logic drivers - 2 inputs are compared and an output generated and amplified thru a single transistor which drives the indicator lamp - think of the comparison the cnip makes as the following - if both inputs are the SAME (ground or 12 volts) the output from the logic is 0 volts and the transistor / lamp will NOT be turned on. If the input pins are DIFFERENT voltages - then the output of the logic goes positive and turns on the transistor and indicator.

parkbrakeexplaination.gif

looking at the image above - if the parking brake is off - the parking brake switch is opened and 0 volts appears at pin 2 of the logic chip - so a logic 0

the pin 1 of the logic chip is forced to logic 0 by being grounded

the chips compares the two - remember - if they are equal inputs - the chip puts out 0 volts and the output transistor Q1 will not be "driven" on to light the indicator.

parkbrakeonexplaination.gif

close the PB switch and current flows thru R3 and R4 - 12 volts flowing thru a total of 1300 ohms = about 1ma of current (1300 / 12). So now there is a voltage drop across both resistors - across the 330 ohm there is (330ohms * .001amps) = 3.3 volts which is above the 2.5 volt threshold the logic circuit needs to see a logic 1 or high input.

so the same comparison is made - if inputs are the SAME - no output - if inputs are DIFFERENT ( which they now are) - the the logic chip powers up the transistor Q1 which turns on the indicator light.

although not shown yet , the test switch bypasses all the logic circuits and forces the transistors to turn on the indicator lamps - i will add the actual circuit later.

Stay tuned for pics of the repaired board - repaired but untested - I need to but a bunch of grain o wheat bulbs - I only have one that is good.

  • Like 2

Share this post


Link to post
Share on other sites

FYI, I am going to move this thread to the FAQ area it's way too good to get lost.

Share this post


Link to post
Share on other sites

This might not be of interest since your repairing a board but this is what a $160 Toro replacement board would look like.

toro003.jpg

Share this post


Link to post
Share on other sites

What software program are you using to draw that schematic? Looks really good so far!

Dan

Share this post


Link to post
Share on other sites

Been watching this with some interest. SOI would a photo of a perfect original 12 pin connector with wiring help any. My 416-H has this set up and after taking a good look, I can't tell the difference between it and new. If it would help I could get a pretty good photo. Dunk

Share this post


Link to post
Share on other sites

Old Iron, So am I to assume that I need to replace 1N4004 Rectifier Diode and the 2N3904 resistor. When looking at the PB lead I see a black clyinder with the silver stripe (rectifier diode) that then leads to a 646 2N 3904 transistor.

Share this post


Link to post
Share on other sites

I bought an Etek digital voltmeter at walmart, what I like is that it has a continuity tester/toner. So I was able to verifiy the traces were ok, when taking measurements compared power diodes, resistors and transistors, the only one I found with major differences was the transistor on the PB circuit compared to the others four, it was only getting about half the readings the others were, (700 compared to 1325 on the other four) I will order a new 2N3904 , replace and let you know whats up.

Share this post


Link to post
Share on other sites

Truckin88

if you would like to replace some components - the 3904 transistors are probably 20-30 cents each , the black barrels are 1N4007 diodes. If 2N3904's are not available, 2N2222 are good replacements.

the IC chip is a quad 2 input exclusive OR gate - less than 50 cents.

I would replace the transistor and diode first as I suspect your failure may be a "leakage current" thru parts that should be turned off - similar to turning off a water hose and seeing some drips out of the hose nozzle - it's "mostly off" but not completely - that can happen in electronics too.

When you replace the transistor, pay attention to the orientation of the flat spot on the body and copy the placement of the leads

When you replace the diode, pay attention to the silver band on the body as your orientation for the replacement part- the silver band represents the CATHODE of the diode.

All these parts are available from a favorite seller of mine

JAMECO ELECTRONICS

IC Chip

http://www.jameco.com/webapp/wcs/stores/se...freeText=74ls86

Diodes

http://www.jameco.com/webapp/wcs/stores/se...freeText=in4007

Transistor

http://www.jameco.com/webapp/wcs/stores/se...freeText=2n3904

  • Like 1

Share this post


Link to post
Share on other sites

Nick,

thanks you very much for the pic

here is the old vs new comparison

diplaypcnnewversion.jpg

Still looks like less than $20 of components - but much more reliable components - I like the LED's but since they are more "directional" in their light output - you might have to be looking at them straight on to see they are lit. An incandescent bulb scatters the light more so it is easier to see off angle from the indicator face. The LED's may not be as bright in direct sunlight too.

But overall a much better design as far as reliability.

:scratchead:

Share this post


Link to post
Share on other sites

Dunk,

that would be GREAT !!

I would love a clean photo of the test switch - maybe slightly separate the wires from each other so they can be clearly identified as to where they attach to the back of the test switch.

Paul F sent out a photo (thanks) that showed what looked like a newer version than the 1987 version I have - He showed 4 wires to the switch - I apparently have 5 wires and are all different colors. I understand wire colors do not always match the diagrams. Your picture may give us a look at another version of the switch

:scratchead:

Share this post


Link to post
Share on other sites

Truckin88

if you would like to replace some components - the 3904 transistors are probably 20-30 cents each , the black barrels are 1N4007 diodes. If 2N3904's are not available, 2N2222 are good replacements.

the IC chip is a quad 2 input exclusive OR gate - less than 50 cents.

I would replace the transistor and diode first as I suspect your failure may be a "leakage current" thru parts that should be turned off - similar to turning off a water hose and seeing some drips out of the hose nozzle - it's "mostly off" but not completely - that can happen in electronics too.

When you replace the transistor, pay attention to the orientation of the flat spot on the body and copy the placement of the leads

When you replace the diode, pay attention to the silver band on the body as your orientation for the replacement part- the silver band represents the CATHODE of the diode.

All these parts are available from an favorite seller of mine

JAMECO ELECTRONICS

IC Chip

http://www.jameco.com/webapp/wcs/stores/se...freeText=74ls86

Diodes

http://www.jameco.com/webapp/wcs/stores/se...freeText=in4007

Transistor

http://www.jameco.com/webapp/wcs/stores/se...freeText=2n3904

picking up the 2n3904 at radio shack, I think this is my problem as the resistance on the meter showed a difference in the one on the PB circuit compared to the other 3904's on the board which all had the same. I also suspect leakage, as when the PB switch is functioning normally when the tractor is on, the light is much brighter when it is staying lit and the tractor is off.

Share this post


Link to post
Share on other sites

Will,

I was just thinking you may want to replace the two green capacitor discs on the board also - about $1 at radio shack - the orientation on these is not critical - place either lead in either hole will work for these caps. Just a thought as these "filter" voltage spikes from the power line and may even act as suppressors for any radio frequency interference picked up from the spark plugs firing. Plus, these are easy to extract and would give you some practice on soldering components onto the PC board

Catalog #: 272-1069 they are .1uf caps rated at 50 volts or greater.

8 cents each at the Jameco site I gave out earlier.

keep me updated :scratchead:

Share this post


Link to post
Share on other sites

Cool, does that IC chip need firmware or to be programmed or is it good out of the box, and does everyone have the same logic circuitry. Also does it matter how it needs to be installed.

Share this post


Link to post
Share on other sites

Will ,

the IC is ready to go out of the box - the manufacture creates the chip specifically to perform certain functions - these functions are identified by their 54LS xxxx numbers.

The chips do have a specific orientation - notice there will be a dimple in the chip body - seen near the black triangle on the picture below. Just mark the pc board with a dot to remind yourself where the new one goes.

Buy 2 or 3 chips (in case you mess up the installation of the first practice replacement)

Picture024-1.jpg

As far as everyone having the same programming - yes, a chip with the same id number (54LS86) will have the same pin for pin function. The 54 xxxxx designates this chip as a military version of the IC - the commercial version will be designated as a 74xxxx which has a slightly less generous operating temperature range. The commercial version won't operate down to -55 degrees like the military version will.

I don't know how experienced you are at DESOLDERING - its different than soldering in new components. Search out desoldering techniques on the internet. You may want to get some desoldering braid from radio shack and maybe even a desoldering iron for a couple $$$ - you can "lift the trace" off the pc board by heating the copper pads too much - it will disolve the adhesive holding the copper to the circuit board - you can repair that issue easily by soldering a wire to the trace and then the component.

Grab a 25 - 35 watt soldering iron and have at it - you will do fine :scratchead:

Share this post


Link to post
Share on other sites

I think this is the final version of the reverse engineering effort on the 1987 416-8 / 312 status indicator circuit board.

Attached Image (Click thumbnail to expand)

post-23-1255549823.gif

Share this post


Link to post
Share on other sites

thanks, my 312 is really clean as it sat in a garage for most of it's life, I will take a pic of the test switch if I get a chance this weekend.

Desolder should be ok

Share this post


Link to post
Share on other sites

GOOD NEWS:

I replaced the 3904 tranistor and it worked like it should.

I had some brand new .1uf caps and a hot solder iron, so I also replaced the two caps, my caps were not green they were smaller and brown, but had the same labelling as the new caps I purchased.

I then tripped the parking break, pto, clutch and seat to make sure they work, which they do, not sure how to trip engine oil. No lights on while off.

I figured it was the transisitor because of the resistance readings, but this post is awesome, thanks old iron!!!!

So in the end a $1.00 fix, biggest thing is to take your time with the solder iron!!!

Share this post


Link to post
Share on other sites

:hide:

Great news Will, thanks for hanging in there and working this thru.

I'm pleased this post gave you the confidence and the resources needed to attempt the repair - like I said before -

"I love the smell of solder in the morning ... smells like victory !"

If you have any other questions about what we did - let me know.

The ENGINE OIL lite - that s a good question - From the circuit board I have, it looks like the light is hardwired directly to the wiring of the tractor oil level switch and does not depend on " electronic logic" to make a decision to turn on - I think you would have to either empty the oil from the engine or remove the switch from the engine block to get the oil lite to turn on.

Has anyone tried this on a tractor with the oil level light during an oil change ??

IF THE OIL IS LOW --- Does the ENGINE OIL lite stay on all the time with the ignition switch turned to RUN / ON or does the lite just turn on when you try to turn the ignition switch to the START position ??

This 146-8 is the first functional tractor I have that has these indicator lites and honestly I have not seen any live in person yet to see how they work or when they turn on. :ychain:

The user manual is a little confusing. It does make a statement about the test switch turning on lites or "flashing lites" - I do know there are some unused blank areas on my circuit board that might support a flasher circuit. This may be a feature available in later model 416's or 312's ??

Maybe someone can chime in with a good explanation for me.

:scratchead:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×