Jump to content

Search the Community

Showing results for tags 'electrical on 520'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Wheel Horse
    • Wheel Horse Tractors
    • Wheel Horse Electric Models
    • Engines
    • Transmissions and transaxles
    • Wheel Horse Electrical
    • Implements and Attachments
    • Restorations, Modifications, & Customizations
    • Pullers
    • WIKI Discussion
  • Wheel Horse Reference
    • Wheel Horse Manuals
    • RedSquare Links
    • Instructional threads and video's
    • Tools and Equipment
  • Europe
    • Euro Introductions
    • Show Pictures
    • Euro Classifieds
  • Picture Gallery
    • Wheel Horse Picture Gallery
    • Implements Picture Gallery
    • Show Pictures
    • LIVE Broadcasts
  • Classifieds
    • Classifieds
    • Haulin Help
    • Vendors
  • General Talk
    • non tractor related discussion
    • Introductions
    • Bumps and Bruises
    • site suggestions, updates, issues
    • Just for Fun
    • other brands
    • Gardening
  • Shows and Events
    • Wheel Horse Collectors Club Show
    • 2017 WHCC Show Pictures
    • RedSquare Herd
    • General Shows and events
  • 520 Club's 520 Specific

Categories

  • Wheel Horse Manuals
    • 1955-1964
    • 1965-1972
    • 1973-1977
    • 1978-1984
    • 1985-1990
    • 1991-1997
    • 1998-2012
    • All years
    • Service Bulletins
  • Implement Manuals
    • Mower decks & reel
    • Blades Dozer Grader Snow
    • Snow Blowers
    • Ground engaging
    • Other
  • Engine Manuals
    • Kohler
    • Onan Service Manuals
    • Other
  • Transmission
    • Manual
    • Automatic / Hydro
  • Electrical
  • Brochures
  • RedSquare Calendars
  • Misc. Items

Blogs

There are no results to display.

There are no results to display.

Categories

  • Records

Categories

  • Wheel Horse for Sale
  • Euro Wheel Horse For Sale
  • Wanted
  • Euro Wanted
  • Trade
  • Euro Trade
  • Non-Wheel Horse
  • Euro non-Wheel Horse
  • Wheel Horse Sold Archive

Categories

  • Tractors
  • Implements

Marker Groups

  • Members
  • Shows and events

Found 1 result

  1. 520 Electrical Problem

    I just acquired a 520H that ran for an hour. After sitting for a few days it started right up and quit after 5 seconds. Turn the key and nothing happens. If it were a fuel problem it would at least turn over. It won't even make a 'click' of the solenoid. I'm guessing the problem is electrical. Battery shows 12.6 volts. Load test for 10 seconds and it still has 12.2 volts. Battery contacts are clean. Have not checked the 'engine ground yet'. Haven't found it yet. Loosened and re-tightened cable connection at starter. Found the 30amp fuse severely burned. Replaced it. Still nothing. Cut the wires to the seat safety switch and soldered them together. Still nothing. Suggestions welcome.
×