Jump to content

WH520

Members
  • Content count

    111
  • Joined

  • Last visited

Community Reputation

17 Good

About WH520

  • Rank
    Advanced Member

Profile Information

  • Location
    Portersville, Pa
  1. 312-8 fuel pump

    Thanks. Unfortunatley I must have cursed myself. I just went to start it and....no fuel lol. Looks like it's time to put an electric pump on it.
  2. 312-8 fuel pump

    So far so good with the new pump. I've gotten twice the life out of it so far than the other ones.....I've mowed the yard 4 times with it lol
  3. 312-8 fuel pump

    Got the new pump and installed it today. It started right up and I let it ran for half an hour. I'll let you guys know if it still starts when I go to mow the yard in 3 weeks. So far I've only been getting 2 weeks out of them lol
  4. 312-8 fuel pump

    I did try pumping them by hand but wasn't getting any suction. However, on the current pump when I plugged both the inlet and outlet I would get a puff of air come out of both sides. Electric is my next step if I have the same problem with the new pump, I was just wanting to try to try to keep it original if I could.
  5. 312-8 fuel pump

    I forgot to mention I also got a new fuel cap since the old one was cracked. I have been using ethanol gas, there is a station not far from me that sells non ethanol, I've just never tried it. Maybe I'll drain the gas out of the tank and fill it up with non ethanol when I put the new pump on.
  6. 312-8 fuel pump

    Hi guys, thought I'd give an update and ask a question. I replaced the fuel pump last fall and mowed my yard twice before the new pump quit working on me. So fast forward to a few weeks ago. I ordered another fuel pump, replaced the fuel lines and put a new petcock on the tank. The tractor fired right up and was running good. Again, I mowed the yard twice and now it's not pumping fuel again. It's getting a good fuel flow from the tank to the pump. Whats the the chances of getting 2 bad pumps and only getting 2-3 hours out of them ? Am I doing something wrong on installation? I just ordered another pump off eBay, I thought I'd try to get some tips off the experts here.
  7. 312-8 fuel pump

    Hi guys, I figured I'd give an update. I ordered a new pump from NAPA and installed it yesterday and it fired right up! Now I've got an issue with one of the deck spindles, always something lol Thanks everybody for your help.
  8. 312-8 fuel pump

    That's good to know, I didn't know there was a screen there. As a matter of fact I did try blowing in the outlet and no air came out. I had forgotten I did that. When I took the line off coming from the tank no gas would come out while I held the line straight up and down (like the position it would be in connected to the pump) It would only start to come out when I got it almost horizontal with the engine. It seemed to be a pretty steady stream coming out though.
  9. 312-8 fuel pump

    Hi everyone, it's been awhile since I've been here. I'm having some issues with my 93 312 with the 12 horse Kohler. Last weekend I went to start it and it wasn't firing at all so I sprayed some carb cleaner in the carb and it fired up for a second but wouldn't restart. I pulled the fuel lines off the fuel pump and had gas going to the pump. I left the line off the pump on the side that goes to the carb and turned it over and gas came shooting out. I hooked the line back and it started right up and ran great for the hour it takes to mow my yard. Fast forward to this weekend. I went out to mow the grass and it's doing the same thing again, not firing. I pulled the line off the pump and turned it over but this time there is no gas being pumped out. I tore the pump apart and from what I could tell everything looked ok. I could hear the check valve clicking on the inlet side when I blew into it. I tried sucking on the outlet side but I couldn't hear anything. I didn't get very good suction on it though because, well, gas fumes don't taste very good lol. Does anybody have any suggestions? Is there a rebuild kit for these or can you still buy a fuel pump? I tried looking them up but didn't have much luck. Thanks guys, sorry for the long post!
  10. 312-8 clutch problem

    It ended up being the simplest repair I've ever done. The return spring for the clutch was caught on the brake so all I had to do was pull back on the pedal and it freed up.
  11. 312-8 clutch problem

    Thanks. I was going to check the belt but after pulling it out with the quad and pushing it back to the driveway I was sick of looking at it lol. It didn't make any strange noises or anything prior to this and the engine sounds like its laboring while in neutral. That tells me it has to be something fairly simple like the belt being bound up. I'm fairly new to the 8 speeds. I've always had hydros in the past so bear with me guys! What I'm doing is widening my drive up about 10 feet and I filled in my 4' deep ditch with brick. I figured I'd try to spread the brick out with the plow on the Wheel Horse. As it turns out the old pig won't move it.......no matter how hard you hit it lol.
  12. Hello everyone, been awhile since I've been on here. About 6 months ago I bought a 312-8 and it's been running great. Tonight I was trying to push something with it that I knew I shouldn't and now I have a problem. The tires were spinning and I pushed in the clutch to put it in neutral, a few minutes later I went to put it in reverse and the clutch pedal would not move at all. Does anyone have any suggestions on where to start?
  13. Have one sitting around you'd like to do for me next? I used Majic IH Red that was sprayed with a gun on my 518 when I repainted it and so far I like it more than the Old WH Red I used the first time. I have bumped a few places on the hood/mule drive while using it and there are nicks in the paint. I can't compare it to Valspar since I've never used it but comparing it to the Old WH Red, it's not as strong. As far as fading goes that's where I like the Majic more than the WH. The tractor is always kept inside but it didn't take very long for it to look pink after painting with the WH paint. The Majic is just as deep and bright as when I painted it.
  14. Hydro jerking

    Sorry, I didn't update the thread, I did find out what the problem was. The mounting plate for the rear end had a crack about 2.5" long. It was flexing the rear end enough when put under pressure to put tension on the hydro linkage to engage the hydro.
  15. It's Raining!!

    Finally getting some rain here with no end in sight. After not having a drop for 5 or 6 weeks with temps in the 90's, I'm enjoying it. There's been big storms heading my way but they always seem to go right past my town over to the next. I knew we were in trouble when I'd wash my truck and it didn't instantly rain :lol:
×