Jump to content

scv85

Inactive
  • Content count

    64
  • Joined

  • Last visited

    Never

Community Reputation

1 Neutral

About scv85

  • Rank
    Member

Profile Information

  • Location
    Stafford Springs, CT
  1. GT 14 Wheel Horse gets a workout

    Awesome find and pic!
  2. GT14 metal on metal noise from pto area

    Correct, it is an electric clutch. So by the sounds of it, if the sealed bearing flung grease everywhere, it's not so sealed anymore and should be replaced. Does anyone know a bearing number, online showed that clutch as an entire unit. Is that bearing even serviceable?
  3. Clunk From Rear

    I was able to duplicate the sound with the parking brake engaged, on the ground, moving either tire very hard forward and reverse. It definitely sounded out towards the wheels more so I quit being lazy and physically checked the hubs. I loosened the locknut and was able to get another full turn out of each bolt. I then tried it on the driveway, forward and reverse and to my surprise, no noise!!! I'm so glad it was nice and simple. Sometimes I'll think the worst and overlook the small things. Thanks for everyones help and thank you wheelhorse of course.
  4. Clunk From Rear

    I measured the play to be about 1/8" either side. I checked the hubs, tight. I checked the pump pulley although I would believe this to be engine speed related if there were an issue, tight. I think you are correct with pinion gear or something, but either way it is looking like I am going to have to open this up. Think I should run it until failure and find a new unit or is this easily repaired... I have never taken a trans apart on one of these.
  5. GT14 metal on metal noise from pto area

    For haha's before pulling the entire pto pulley off, I took out the clip and pin, undid the electrical connector and spun the outermost part of the pulley setup. About halfway around I get a little grind/scrap type noise. I'm not sure what kind of clutch this uses but it definitely is rubbing at one point internally. Now my next question is... is this going to cause a problem, self destruct or should it be okay. The clutch engages wonderfully and does not slip or anything.
  6. So I recently adapted a Johnson loader to my 70 GT14. I was using it this weekend when I noticed a bit of metal on metal noise from the pto area. It has not gotten worse, but it almost seems like a bearing. I did notice a while back that it looked like some grease was thrown out of the front of the pto where it bolts on. Am I looking at a pto bearing failure and is it at all common?
  7. Clunk From Rear

    I put the rear up in the air, the axles have some in and out play both sides but no up and down play. I would assume the axle seals would be leaking if there were up and down play. Is this in and out play normal? I could not duplicate the clunk by turning the tires, only intermittently when going forward or reverse from a stop.
  8. Clunk From Rear

    I will get it up this week and see if there is any play. Where were his axles actually loose, internally or were the hubs just loose on the axles?
  9. So I've been noticing a clunk from what seem like the trans or the rear. It only happens when I start to engage forward or reverse from a stand still. It does not happen all of the time, but it does concern me. Any ideas???
  10. So after some tinkering here and there when I had time and some trouble shooting and blowing an old johnson loader piston to pieces, my GT14 has a johnson loader, a 3 pt hitch and a 350lb counter weight!!! I will be trying it out tomorrow and putting some real weight in it to make sure it will handle it and not leak. I will get some pictures together as this entire restoration is coming to a close. Now its time to make this horse work!!!
  11. So I am just finishing up my loader setup for my GT14 and I had a question about the hydraulics. I first had a 3/8" line running to the pump with a 1/2" line from the pump to the joystick. The system worked well and would not bogg the tractor. A wise friend noticed the sizes of line and advised me to change the feed line to 1/2" as well. So now I have 1/2" to the pump, 1/2" to the joystick from the pump and 3/8" as a return from the joystick. The loader now seems to bogg a bit when operating the loader, but other than that works fine. My question is, are these lines correct sizes and is it normal for it to bogg down a bit when operating the controls?
  12. GT14 Transmission Leaking

    I checked the pump to case bolts on lunch, I was able to snug all of the bolts and the forwardmost lower bolt was very loose. I will clean it back up and run it again but even if that wasn't the problem, it was going to be a problem.
  13. GT14 Transmission Leaking

    It looks like seal here the pump bolts up, I'll try tightening bolts tonight.
  14. GT14 Transmission Leaking

    I did just save the transmission manual if it helps any... Trans Manual Just click the red link for the sunstrand hydro trans. Hopefully someone has some input.
  15. So previously I had a slight leak from both axle shafts on the trans of my 70 GT14. I replaced them and it was okay. I now notice some drips from the center of the trans on the ground. Is this something I should address or will I be okay just checking fluid now and again? I am a neat freak so the spot I am getting is about 2"x2" after running it for an hour or so and then parking it for the week.
×